T-Mobile Message Latency

Incident Report for Vibes

Resolved

T-Mobile has RESOLVED the SMS and MMS message latency on their network. All impacted messages have been delivered.

IMPACT: SMS and MMS message latency on T-Mobile from 12:01 p.m. CT to 2:05 pm. CT.
Posted Nov 19, 2025 - 14:49 CST

Monitoring

Vibes has identified latency with SMS and MMS message delivery to T-Mobile. We will provide updates as they become available.

IMPACT: SMS and MMS message latency on T-Mobile. Both inbound and outbound messages may experience delays in being delivered.

ACTION: No action is required; all messages are being queued and will be processed at the rate the T-Mobile network is available to Vibes.
Posted Nov 19, 2025 - 12:06 CST
This incident affected: North America Messaging (SMS SMPP, SMS HTTP, MMS) and North America Platform (SMS, MMS).