10DLC message latency: T-Mobile

Incident Report for Vibes

Resolved

The message latency on 10DLC carrier partners T-Mobile network has been resolved. All queued messages have been delivered.

IMPACT: 10DLC CARRIER NAME message latency from 2026-03-28 18:59 CT to 2026-03-28 20:52 CT.
Posted Mar 28, 2026 - 21:33 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2026 - 20:50 CDT

Investigating

Vibes has identified message delivery latency to our 10DLC partner on T-Mobile. We will provide updates as they become available.

IMPACT: 10DLC Message latency on T-Mobile. Messages both inbound and outbound to Vibes may experience delays in being delivered.

ACTION: No action is required; all messages are being queued and will be processed at the rate the 10DLC network is available.
Posted Mar 28, 2026 - 19:48 CDT
This incident affected: North America Messaging (10DLC).