T-Mobile has RESOLVED the SMS message latency on their network. All impacted messages have been delivered.
IMPACT: SMS message latency on T-Mobile.
Posted Nov 10, 2025 - 08:55 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 09, 2025 - 16:45 CST
Update
T-Mobile continues to experience SMS message latency on their network. We are in direct communication with them. Vibes will continue to update you as we receive information.
Posted Nov 08, 2025 - 20:48 CST
Update
T-Mobile continues to experience SMS and MMS message latency on their network. We are in direct communication with them. Vibes will continue to update you as we receive information.
Posted Nov 08, 2025 - 16:32 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 08, 2025 - 12:38 CST
Monitoring
T-Mobile continues to experience SMS _ message latency on their network. We are in direct communication with them. Vibes will continue to update you as we receive information.
Posted Nov 08, 2025 - 08:26 CST
Identified
Vibes has identified latency with SMS message delivery to T-Mobile. We will provide updates as they become available.
IMPACT: SMS message latency on T-Mobile. Outbound messages may experience delays in being delivered.
ACTION: No action is required; all messages are being queued and will be processed at the rate the T-Mobile network is available to Vibes.
Posted Nov 08, 2025 - 03:34 CST
This incident affected: North America Messaging (SMS SMPP, SMS HTTP) and North America Platform (SMS).